Обратная связь
×

Обратная связь

Обновление плагинов в Firefox

    29 августа 2012 в 16:35
  • 6,2
  • 4311
  • 1
  • 6,2
  • 4311
  • 1

В связи с вышедшим пару дней назад обновлением для моего любимого браузера Mozilla Firefox (теперь последняя стабильная версия — 15), решил рассказать об обновлении плагинов, потому как сам недавно столкнулся с проблемами из-за устаревших версий плагинов. Не стану рассказывать, почему чрезвычайно важно держать версию браузера и его дополнений актуальными — от этого зависит безопасность вашего компьютера и комфорт во время серфинга. Просто поверьте, что это — очень важно.

Вы уже наверняка привыкли к тому, что все дополнения обновляются автоматически. Максимум, что от вас время от времени требуют — нажать кнопку «Обновить». Но плагины и дополнения — это немного разные вещи. Дополнения — это Adblock Plus, Flashgot, Firebug и т.д. А плагины — это Adobe Flash Player, Silverlight, Java. Разница в том, что плагины сами по себе не обновляются (ну кроме Flash, который при загрузке системы проверяет обновления), потому что плагины обычно ставятся во время установки ПО, добавляя свой плагин в браузер, а сам этот софт вы можете даже и не думать обновлять. Поэтому, чтобы всё работало и ваша версия плагина не была уязвимой, я расскажу как их обновлять.

Сам я недавно столкнулся с проблемой — в определённый момент, в FF у меня начали наслаиваться друг на друга интерактивные Flash-элементы. Это просходило во время скроллинга и невероятно бесило меня. Я решил докопаться до истины и полез в Firefox — Дополнения. Все расширения были последних версий, как и браузер, который только что обновился до 15-ой версии. И тут я заметил, что в плагинах есть ссылка "Проверить актуальность версий установленных у вас плагинов". Ок, кликнул, открылся сайт Mozilla и начал проверку. Как я и думал — версия Java оказалась устаревшей, помимо этого у меня стояла старая версия Silverlight, Acrobat и Shockwave вместе с Flash. Там, где вы увидите, что у вас установлена устаревшая версия, есть ссылка на сайт производителя плагина, откуда можно скачать свежак.

Обновление продуктов Adobe всегда происходит легко, Silverlight тоже устанавливается просто, а вот с Java есть один нюанс. У меня установлена 64-битная ОС, так что я со всей уверенностью качал 64-битную версию Java. Но, после того, как я установил её несколько раз, а плагин так и не обновился, я задумался: а может быть Яву не интересует версия системы, и вместо этого она увлекается версия браузера? Слил 32-битную версию, установил — всё в порядке. Ролики перестали наслаиваться и утекать вниз, новая версия FF стала ещё быстрее предыдущей — все счастливы!

Проверить, какая версия FF установлена у вас, можно с помощью служебного раздела, вызываемого командой about:support в адресной строке. Если там нет ничего, связанного с 64 — значит у вас 32-битная версия. Там может быть слово WOW64 (Windows-on-Windows 64-bit), но оно как раз означает, что у вас 32-битная версия браузера.

Даже если у Вас не Firefox, советую обновить плагины вручную в любом случае — это полезно во всех смыслах. Правда, я не уверен, что в других браузерах есть способ проверки актуальности плагинов.

Всех благ!

Теги: IT , firefox , java , flash , silverlight , acrobat , shockwave

1 комментарий

104 Korben
29 августа 2012, 16:35